Zurück zu Laptopbau

Problem Grafikkartenwechsel

Bei den meisten Laptops, zum Teil auch bei eigentlich hochwertigen Modellen, wie dem Dell Precision M4500, ist die Grafikkarte fest auf dem Mainboard verlötet. Es sei hier erwähnt, dass ab dem Precision M4600 (und diverser, empörter Beschwerdeanrufe meinerseits beim Dell-Support) ein MXM 3.0A-Steckplatz in der Precision-Serie zum Einsatz kommt. Ich jedenfalls achte jetzt sehr genau darauf, dass die Grafikkarte wechselbar ist, denn oft ist die Grafikkarte das erste Element, das kaputt geht. Auch ist die Auswahlmöglichkeit verschiedener Grafikkarten beim Laptopkauf noch kein sicheres Indiz für das Vorhandensein eines MXM-Steckplatzes. Oft werden verschiedene Mainboards eingebaut.
Laptops mit einem solchen Steckplatz zu finden ist nicht ganz einfach.

Ich kenne als MXM-Laptops folgende Systeme:

Natürlich gibt es weitere MXM-Laptops, zum Beispiel einige Modelle von MSI oder HP, aber damit hatte ich bislang nicht näher zu tun und habe hier nur Laptops aufgelistet, mit denen ich Erfahrungen habe.

Und hat man ein MXM-Laptop, geht der Spaß erst richtig los:

Laptopgrafikkarten (und -prozessoren) müssen über dubiose Ebayshops eingekauft werden und das meist ohne Rückgaberecht oder Garantie, dass es funktioniert, denn oft funktionieren HDMI, Standby oder andere Features nach einem Grafikkartenwechsel nicht mehr, auch wenn einem besagte Grafikkarte als "kompatibel" verkauft wurde. Dafür verantwortlich ist das sogenannte VBIOS, ein kleiner Chip auf der Grafikkarte, der die Kommunikation mit dem Mainboard, sowie Taktgeschwindigkeit, Lüfterpegel, Anschlüsse u.Ä. regelt. Während Desktopgrafikkarten meist ihre eigenen Bildschirmanschlüsse und Lüfter mitbringen, und ein nicht 100%ig kompatibles VBIOS daher kein Problem ist, ist es bei Laptops unverzichtbar, dass diese Dinge funktionieren. Erschwerend kommt bei Laptops diverser Schnickschnack, wie Optimus/Enduro, hinzu, der die VBIOS-Kompatibilität nicht gerade fördert. Zwar können mit Optimus unkomplizierter Grafikkarten zwischen Laptops unterschiedlicher Hersteller gewechselt werden, die aber die gleiche Prozessorgeneration verwenden, aber die Kompatibilität zu Laptops mit einer anderen Prozessorengeneration wird noch schwieriger.

Folgende Grafikkartenwechsel habe ich bereits durchgeführt:

Grafikkarte Laptop Verhalten
AMD HD 8970M Clevo P150HM Habe die Karte gekauft, als sie gerade ganz neu auf dem Markt war. Sie wurde mir mit einem MSI-VBIOS darauf geschickt und in meinem P150HM nicht erkannt. Es passierte das gleiche, wie wenn ich ohne Grafikkarte bootete: Bildschirm blieb schwarz, nach einiger Zeit drehte der Lüfter maximal auf und ich bekam einen BIOS-Beebcode. Danach schaltete sich das Laptop ab. Ich habe die Karte dann zu SVL 7 geschickt (Ein BIOS-Modder). Er konnte sie zwar in einem Alienware M15x zum laufen bringen, und eigentlich hätte es damit auch in meinem P150HM funktionieren sollen, jedoch tat es das nicht (Gleiches Verhalten, wie vorher). Habe dann gegen eine 7970M (das Vorgängermodell) getauscht, das angeblich im HM funktionieren soll. http://forum.notebookreview.com/sager-clevo/731651-p150hm-gpu-upgrade-7970m-vs-680m.html, 2014.12.18
AMD HD 7970M Clevo P150HM Gleiches Problem, wie 8970M.
AMD HD 7970M Clevo P150EM Da das EM die Intel HD Grafik primär einsetzt, konnte ich zunächst booten, auch mit Bild. Die Karte wurde im BIOS erkannt. Nach etwa 30 Sekunden fuhr dann aber auch der Lüfter hoch und das Laptop piepste dauerhaft. Nach etwa einer Minute schaltete es sich ab. Ich konnte vorher noch ein Flashtool ausführen oder Windows starten. Die Karte wurde in Windows im Gerätemanager als Standard-VGA erkannt, jedoch mit der Fehlermeldung, das Gerät könne nicht gestartet werden. Das Flashen des VBIOS war ebenso nicht möglich. Ich bekam die Meldung, der VBIOS-ROM sei gelockt, der entsprechende Unlock-Befehl half nicht.
Nvidia Quadro K5000M Clevo P150HM Grafikkarte funktionierte, jedoch gingen HDMI, DVI-D und Standby nicht. Nach dem Standby blieb der Bildschirm schwarz, das System lief zwar im Hintergrund, aber nur zum Teil, lies sich zum Beispiel nicht herunterfahren oder bedienen. Auch bei Linux gleiches Verhalten. Ein Live-Linux von DVD zeigte nach dem Standby zwar ein Bild, jedoch frohr dieses nach etwa einer Sekunde ein. Das VBIOS der Karte ist wohl aus einem Dell Precision M6600, Version 80.04.33.00.35.
Nvidia Quadro K5000M Clevo P150EM Grafikkarte funktioniert, auch Standby und externe Anschlüsse außer DVI-D. Dass HDMI und Displayport funktionieren ist auf Optimus zurückzuführen, da alle Bildschirmausgänge beim EM hinter der Intel HD Grafik hängen.http://monitor.espec.ws/files/p150em_935.pdf, Seite 60, 2014.12.18 Optimus selbst funktioniert jedoch nicht. Die K5000M schaltet sich im Leerlauf nicht ab, die Leerlaufleistung beträgt 40W in Windows und 30W in Kubuntu (Auch, wenn es mir dort bislang nicht gelungen ist, den Nvidia-Treiber zu installieren). Mit der gleichen Karte im HM hatte ich unter Windows nur 30W Leerlaufleistung. Während dem Booten spielt der Lüfter etwas verrückt.
Nvidia GTX 580M Clevo P150EM Grafikkarte funktionierte. Im Gerätemanager wurde sie als Standard-VGA erkannt, jedoch mit Fehlermeldung "Gerät kann nicht gestartet werden.". Der Treiber lies sich erst nach Anpassung der nvdmi.inf installieren. Danach stürtzte die Nvidia-Systemsteuerung sofort nach dem öffnen immer ab, auch brachte die Karte nicht die volle Leistung. Windows bewertete statt der GTX 580M nur die Intel HD Grafik, beim spielen verriet der Lüfter zwar, dass die Karte arbeitete, jedoch nur mit halber Leistung; Nvidia Inspector zeigte, dass die Temperatur nicht über 58°C anstieg (Normal wären um die 80°C). Die Karte wurde mir mit einem Alienware-VBIOS geschickt, ich habe dann das neuste Clevo-VBIOS aufgeflasht, in beiden Fällen aber mit gleichem Ergebniss. Angeblich ist die GTX 580M identisch zur GTX 675M http://forum.techinferno.com/clevo-reviews-owners-lounges/8509-p150em-gtx-580m.html#post116533, Seite 60, 2014.12.26, also hätte ich das 675er VBIOS aufspielen müssen, damit sie im P150EM arbeitete, aber ich habe die Karte eigentlich für das HM gekauft, wo sie auch ohne Probleme funktioniert, da offiziell unterstützt.
Quadro K5000M HP Elitebook 8770w Habe meine Quadro in meine "neue" Workstation umgezogen. Im Prinzip geht alles; einzige Auffälligkeit: Es wird offenbar kein Ton über den Displayport übertragen. Der digitale Audioausgang wird in der Systemsteuerung angezeigt, aber immer als nicht verbunden. Ein original HP-VBIOS ist nicht auffindbar. Habe im Forum danach gefragt; beim Support wusste man nicht, was ein VBIOS ist...
ATI Fire Pro M4000 Clevo P150EM HP VBIOS, habe diese Karte in mein altes P150EM eingebaut, um dieses hochfahren zu können. Im BIOS wird die Karte nicht erkannt, in Windows als Standard VGA. Die Intel HD Grafik läuft, aber wenn man versucht, den AMD-Treiber zu installieren, (der allgemeine Radeon-Treiber lässt sich installieren) dann gehen beide Grafikkarten nicht mehr richtig. Musste dann das System neu installieren, das es anders nicht hinzubiegen war. Diese Grafikkarte ist also nur als Platzhalter brauchbar, damit das Laptop bootet; ob der etwas unpassene MXM 3.0b-Kühler die MXM 3.0a-Karte bei voller Leistung richtig kühlen würde, sei mal dahingestellt.